Node.js Lambda functions failing in eu-west-1
Incident Report for Lumigo
Resolved
This incident has been resolved.
A fix has been deployed, tested and verified.
We advise any customer who has not yet updated their Node.js tracer version to 1.80.1 or above, to do so with urgency.
Posted Mar 14, 2023 - 20:45 IST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 14, 2023 - 18:16 IST
Update
We are continuing to work on a fix for this issue.
Posted Mar 14, 2023 - 14:15 IST
Identified
CRITICAL:
Lambda functions in eu-west-1 with the Lumigo Node.js tracer are failing. To fix this, please update to the latest version of the Lumigo Node.js tracer ASAP. As a precaution, we strongly advise updating the Node.js tracer in your Lambda functions in all regions. For assistance and/or guidance in updating your functions, please reach out immediately to support@lumigo.io.
At approximately 01:06 PM PST (GMT-7) on 13/03, the format of the AWS Lambda environment variable X-AMZN-TRACE-ID changed in AWS region eu-west-1. This is causing Lambda functions in this region with the Lumigo Node.js tracer installed to fail.

- This issue only affects functions in eu-west-1
- This issue only affects functions with the Lumigo Node.js tracer installed.
- The fix has been implemented at 04:16 PM PST (GMT-7) 13/03, and is included in tracer version 1.80.1 or newer.
Posted Mar 14, 2023 - 12:52 IST
This incident affected: Tracer.