Issues with autotrace for Node.js 18 functions defined as modules
Incident Report for Lumigo
Resolved
This incident has been resolved.
Posted Dec 20, 2022 - 20:47 IST
Update
We are continuing to monitor for any further issues.
Posted Dec 20, 2022 - 17:08 IST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 20, 2022 - 17:08 IST
Update
Update about the Lambda Node + mjs (a.k.a “ES modules” / “ESM” / “EcmaScript Modules”) situation: we think we have a fix for the Node.js tracer that would restore auto-trace for all known use cases (including .cjs that was so far not supported). We are going to run very stringent tests for it. ETE by EoD, assuming we do not find further issues.
Posted Dec 20, 2022 - 13:25 IST
Update
We are working on it to restore the full functionality
Posted Dec 20, 2022 - 00:04 IST
Identified
We have seen a spike of issues related to auto-tracing Lambda functions using the Node.js 18 runtime. We believe this is related to the fact that we have not yet implemented support for .mjs files, and when auto trace is applied, the Lumigo Node.js tracer may fail to find the original handler to dispatch function calls to.
We are disabling the support for auto-tracing Node.js 18 on new functions until the issue is resolved. We are very sorry for the inconvenience.
Posted Dec 19, 2022 - 19:24 IST
This incident affected: Tracer.